การแจ้งเตือน
ลบทั้งหมด

[ขอคำแนะนำ] Save หน้าเว็บแล้ว Page Builder สลับเป็น Code Editor ทำหน้าเว็บพัง

   RSS

0
หัวข้อเริ่มต้น

สวัสดีครับทุกท่าน

ผมตกแต่งหน้าหลักของเว็บด้วย Page Builder by SiteOrigin โดยใช้ Row / Widget อะไรปกติ
แต่ล่าสุดพบปัญหาตอนเพิ่ม Row เข้าไปบนหน้า แล้วใช้ HTML Widget พอกดปุ่ม อัปเดต

ปรากฎว่า หน้า editor ที่เคยเป็น Page Builder สลับไปเป็น Code Editor อัตโนมัติเฉยเลย
พอมันเปลี่ยนเป็น Code Editor แล้ว จะเปลี่ยนกลับมาเป็น Page Builder ก็ไม่ได้แล้วใช่ไหมครับ
เพราะโค้ดมันจะไม่เหมือนเดิมแล้ว จึงทำให้ Layout หน้าเว็บหลัก รวนและพังไปเลย

ผมลอง restore แล้วทำแบบเดิมซ้ำ ปรากฎว่าก็ยังเจอปัญหาแบบเดิม
- ผมลองสร้างหน้าใหม่ด้วย Page Builder ใส่ Row เยอะๆ ใส่ HTML Widget กับ ตัวอื่นๆ ก็ไม่เห็นเป็นอะไร เวลาบันทึกก็จะกลับมาที่ Page Builder แบบเดิม

เลยอยากสอบถามว่า มีท่านใดเคยพบปัญหาในลักษณะนี้บ้างว่าเกิดจากสาเหตุใด

ขอบคุณล่วงหน้าครับ

หัวข้อนี้ได้รับการแก้ไข 8 เดือน ที่ผ่านมา 2 ครั้ง โดย Jingjoe
แท็กหัวข้อ
2 คำตอบ
0

อาจจะมี plugin บางตัวชนกันได้นะครับ ลองเทสด้วยการปิด plugin ตัวอื่นๆ ทั้งหมดดูว่าอาการหายไหมนะครับ

@k สวัสดีครับ ผมลองไล่ปิด plugin แล้วครับ ก็ยังไม่ใช่ ตอนแรกคิดว่าเป็นที่ Shortcode ครับ แต่ก็ไม่ใช่

จนไปลองลบ Row ที่เป็น 8 Columns ซึ่งใช้ Widget รูปภาพทำเป็น Logo เรียงๆ กันไว้ออกไปครึ่งหนึ่ง ปรากฎว่าอาการหายไปพักนึง

หลังจากนั้นไม่นาน ผมเพิ่ม Widget HTML (ตัวพื้นฐาน) เข้าไปในแถวอื่น ล่าสุดพบอาการเด้งจาก Page Builder ไปที่ Code Editor อีกเช่นเคยครับ

ผมเลยไม่แน่ใจว่าในหน้าหลัก ผมแบ่ง Row แบ่ง Column หรือใช้ Widget เยอะเกินไปหรือไม่, Page Builder มีข้อจำกัดอะไรประมาณนี้ไหมครับ

ตอนนี้เลยต้องใช้วิธี ทำไปสักพักแล้ว Backup เป็นช่วง ๆ ครับ แต่ก็ยังหาสาเหตุไม่เจอครับ

0
หัวข้อเริ่มต้น

[UPDATE]

ผมเดาว่าน่าจะเจอสาเหตุคร่าว ๆ แล้วครับ คาดเดาว่าอาจจะเกิดจากประเด็น "จำนวน Row หรือ Column" ที่สร้างใน Page Builder

โดยผมลองสร้างหน้า Page ใหม่ แล้ววางโครงสร้างให้เหมือนหน้าหลักมากที่สุด แล้วก็ Save ไปเรื่อยๆ

พอผมลองแบ่ง Row ให้มากขึ้นเป็น 4 columns แล้ว Duplicate หลาย ๆ แถวแล้ว Save คราวนี้แหละ

หลังจาก Save มันสลับจาก Page Builder ไปเป็น Code Editor อัตโนมัติเลย

 

แต่ก็ยังคงไม่เข้าใจว่า การสร้าง Row กับ Column ประมาณจำนวนหนึ่ง ทำไมถึงเป็นสาเหตุให้เกิดปัญหานี้ได้

ลองเข้าไปที่ Support Forum ใน siteorigin น่าจะมีคนหนึ่งที่เจอปัญหาคล้ายๆ กัน แต่เขาคาดเดาว่าน่าจะเกิดจาก Post Carousel

แต่ทาง support น่าจะให้ความเห็นประมาณว่า Page Builder Plugin กับ Bundle Plugin ไม่น่าจะ conflict กันได้ครับ

สรุปแล้วก็ยังคงต้องใช้วิธี Back up ไปเรื่อย ๆ จนกว่าจะหาสาเหตุที่แท้จริงได้ครับ 

@jingjoe คือ น่าจะเป็น bug ของตัว site origin เองเลยใช่ไหมครับ ขอบคุณที่มาแบ่งปันครับผม

แบ่งปัน: